Removal of support for TLS protocol 1.0 and 1.1 *UPDATED*


Brightidea has removed support for TLS 1.0 (as of July 1st, 2017) and will remove support for TLS 1.1 encryption on February 1st 2019.

Brightidea will require TLS 1.2 or higher for all connections after February 1st 2019.

What is TLS?

TLS stands for “Transport Layer Security.” It is a protocol that provides privacy and data integrity between two communicating applications. It’s the most widely deployed security protocol used today, and is used for web browsers and other applications that require data to be securely exchanged over a network. TLS ensures that a connection to a remote endpoint is the intended endpoint through encryption and endpoint identity verification.

Why is this happening?

Transport Layer Security (TLS) 1.0 and 1.1 are old protocols used for encrypting communications between a browser and a web server. TLS 1.0 and 1.1 have a number of potential vulnerabilities and is no longer considered to be secure.

What is the change?

Brightidea is disabling support for the TLS 1.0/1.1 encryption protocol. Any attempt to access Brightidea using TLS 1.0/1.1 will result in an error page and the connection will fail. 

How will customers be impacted?  

TLS v1.2 or above must be enabled as of February 1st, 2019 in an effort to maintain the highest security standards and promote the safety of Brightidea customer data. 

What needs to be done?

If you and your users are already using up-to-date browser versions and web application tools, you are probably already using TLS 1.2 or later so nothing needs to be done!

For older versions of Internet Explorer:

    • This mainly affects IE 9 and 10 only since other browsers don’t use TLS 1.0/1.1.
      • Internet Explorer 10 and below users will need to be configured to allow TLS 1.2:
        1. Go to Tools and select Internet Options
        2. Select the Advanced tab in Internet Options
        3. Enable (check) "Use TLS 1.2"
        4. Click OK

Any custom API applications will not be able to access the Brightidea API if they do not support TLS 1.2 or above. Such applications must be upgraded as well.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk